This is TikiWiki 1.9.7 -Sirius- © 2002–2006 by the Tiki community Fri 21 of Sep, 2018 [17:46 UTC]

Forum: Hot Heads Tech Talk

Forums->Hot Heads Tech Talk->OEM core (frost) plugs

willys392
OEM core (frost) plugs


How many of you have built an early Hemi using the OEM core (frost) plugs and have you had any bad history using them. I am currently building a 392 and was going to use the OEM plugs until I read that others were having problems with them blowing out under pressure. Apparantly Hot Heads Research do not sell them because of this fact. Anyone had issues....

cheers
Bill
  user offline
on: Sat 04 of Aug, 2012 [18:02 UTC] reads: 10145

Posted messages

Top
author message
willys392
user offline
Re: OEM core (frost) plugs
on: Sat 04 of Aug, 2012 [19:06 UTC] score: 0.00
disregard this post, I have read the post by mtsmopar and I guess I have a decision to make, sorry for the waste of time, I should have sorted thru the posts a little more carefully

How many of you have built an early Hemi using the OEM core (frost) plugs and have you had any bad history using them. I am currently building a 392 and was going to use the OEM plugs until I read that others were having problems with them blowing out under pressure. Apparantly Hot Heads Research do not sell them because of this fact. Anyone had issues....
>
> cheers
> Bill

author message
George
user offline
Re: Re: OEM core (frost) plugs
on: Sat 04 of Aug, 2012 [19:40 UTC] score: 0.00
> disregard this post, I have read the post by mtsmopar and I guess I > > cheers
> > Bill

I've used the OEM ones with a little JB Weld W/O problems.


Page: 1/1

Show posts: